Dave Perrett

'Can't Find Magick-config' Error Installing Rmagick Gem

linux, programming, quickie, ruby, web

If you are getting the error ‘Can’t find Magick-config’ when installing the RMagick gem, chances are you’re missing the libmagick9-dev library.

1
2
3
4
5
/opt/ruby-enterprise-1.8.6-20090201/bin/ruby extconf.rb install rmagick
checking for Ruby version >= 1.8.2... yes
checking for gcc... yes
checking for Magick-config... no
Can't install RMagick 2.9.1. Can't find Magick-config in .....

To fix this on ubuntu, simply install libmagick :

1
apt-get install libmagick9-dev